Rowan System Status
Subscribe To Updates

Phone call issues affecting Savitz Hall

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue impacting phone service in Savitz.

Please do not hesitate to contact the Technology Support Center if you have any questions.
Posted May 27, 2025 - 12:15 EDT

Investigating

Information Resources & Technology is investigating an issue affecting phone services in Savitz Hall on the Glassboro campus.

The Registrar, Housing, and Financial Aid Departments in Savitz Hall report that some phone calls are not going through to them, as well as poor audio for the calls that do go through.

We are working to address this issue as quickly as possible, and we will provide an update when more information is available.
Posted May 23, 2025 - 14:10 EDT
This incident affected: Internet, Networking & Phones (Phones & Voicemail).