Rowan System Status
Subscribe To Updates

ProConnect issue affecting access

Incident Report for Rowan University

Resolved

JAGGAER US PRODUCTION has resolved the issue impacting access to ProConnect.

The ProConnect application is now available.
Posted Sep 19, 2025 - 14:15 EDT

Investigating

Information Resources & Technology is aware of an issue reported by our vendor that is affecting access to ProConnect.

From the vendor: JAGGAER US PRODUCTION Environment began experiencing performance issues around 1:06 PM EST today, September 19, 2025. Our technical resources are engaged and working to identify and resolve this issue as quickly as possible.
Posted Sep 19, 2025 - 13:42 EDT
This incident affected: Other Software & Applications (Rowan ProConnect).