Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 06:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 18, 2025 - 11:20 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 18, 2025 - 11:19 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 18, 2025 - 11:16 EDT
Scheduled
Eduroam, a wireless network for visitors from other colleges and universities, may be intermittently unavailable on Friday, March 21, from 6 a.m. to 8 a.m. due to system testing.
Guests on campus who would normally use Eduroam may connect to RowanWiFi if they need wireless internet access during this time frame. To connect to RowanWiFi as a guest:
1. Select RowanWiFi 2. Click to sign in under "Guests and Visitors" 3. Accept the Terms of Use and click Connect