Rowan System Status
Subscribe To Updates

Issues accessing ProConnect and related sites

Incident Report for Rowan University

Resolved

JAGGAER US PRODUCTION, vendor of ProConnect has resolved the issues impacting access to eProcurement, Invoicing, Contracts+, Supplier management, Inventory management, and Sourcing.

All modules are available.
Posted Jun 03, 2025 - 07:09 EDT

Identified

JAGGAER US PRODUCTION Environment began experiencing performance issues around 4:25 PM EST today, June 02, 2025. Our technical resources are engaged and working to identify and resolve this issue as quickly as possible.

Products Impacted: eProcurement, Invoicing, Contracts+, Supplier management, Inventory management, and Sourcing.
Posted Jun 02, 2025 - 17:10 EDT
This incident affected: Other Software & Applications (Rowan ProConnect).