Information Resources & Technology has resolved the issue impacting access to Outlook and other Microsoft applications through Citrix.
If you were affected by this issue, please close all Office applications and restart them.
If you have any questions, please contact the Technology Support Center at 856-256-4400.
Posted Aug 24, 2026 - 11:16 EDT
Investigating
Information Resources & Technology is investigating an issue affecting access to Outlook through Citrix.
Some users may receive the following error when accessing Outlook:
“Your admin needs to assign an Office license to this device so you can edit your files.”
We are working to address this issue as quickly as possible and will provide an update when more information is available.
Posted Aug 24, 2026 - 10:00 EDT
This incident affected: Academic Systems (Virtual Academic Desktop in Citrix) and Business Systems (Virtual Employee Desktop & Applications in Citrix).