Information Resources & Technology has resolved the issue that prevented the renewal of positions in RIMS.
All expiring positions can now be renewed.
Posted Nov 15, 2025 - 09:34 EST
Identified
Information Resources & Technology has found the issue preventing you from renewing expiring positions in RIMS.
An update will be provided when the fix is implemented.
Posted Nov 14, 2025 - 13:47 EST
Investigating
Information Resources & Technology is investigating an issue that is preventing the renewal of positions in RIMS.
When attempting to renew a RIMS position, users are receiving an error directing them to “select a position,” even when a position has already been selected.
We are working to address this issue as quickly as possible and will provide an update when more information is available.
Posted Nov 14, 2025 - 08:24 EST
This incident affected: Other Software & Applications (RIMS (rims.rowan.edu)).