Rowan System Status
Subscribe To Updates

Issues sending and receiving some emails in Outlook: 7-12-25

Incident Report for Rowan University

Resolved

Emails are now being received if you email support@rowan.edu.

Please contact the Technology Support Center if you have any questions.
Posted Jul 12, 2025 - 20:03 EDT

Update

Information Resources & Technology has resolved the issue that impacted the sending and receiving of some emails in Outlook.

However, if you email support@rowan.edu with an issue or question, you will not receive the email confirmation. Technicians are working on resolving this issue. Updates will be provided as they are available.
Posted Jul 12, 2025 - 19:34 EDT

Investigating

Information Resources & Technology is aware of an issue impacting the sending and receiving of some emails in Outlook

Technicians are actively working on resolving this issue. Updates will be provided as they are available.

Gmail is not affected.
Posted Jul 12, 2025 - 16:11 EDT
This incident affected: Microsoft 365 (Exchange Email (outlook.office.com)).