Information Resources & Technology has resolved the issue with the Rowan Print Driver Installer, but you may need to reboot your computer. If you are unable to install new printers, please restart your machine and try again.
If you are still unable to install a printer, please contact us for help at 856-256-4400.
Posted Mar 24, 2025 - 10:14 EDT
Investigating
Information Resources & Technology is investigating an issue with the Rowan Print Driver Installer, a tool that allows employees to set up printers on their Rowan-owned PCs on their own.
Currently, this tool is not working for new printer installations. Employees who set up network printers before this issue started on Wednesday, March 5, should still be able to print as expected. We are working with our vendor to resolve this issue, but we do not currently have a timeline for resolution.
If you are unable to install a Rowan network printer on your PC, you have two options until this issue is resolved:
1. Add the Rowan Copier queue from Company Portal and pick up prints from the nearest copier. - Go to Start Menu > Company Portal - Select Apps in left-hand menu - Filter by category along the top of the main window - Select Printers > Rowan Copiers
2. Upload your document to our Mobile Print service at mobileprint.rowan.edu and pick it up at one of the printers connected to this service or any copier with a RowanCard reader.
Posted Mar 12, 2025 - 13:44 EDT
This incident affected: Printing (Network Printing).