Rowan System Status
Subscribe To Updates

Some applications experiencing latency

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue that was causing latency with some applications.

All services should now be operating as expected.
Posted Aug 27, 2026 - 12:34 EDT

Investigating

Information Resources & Technology is aware of latency affecting several applications.

We are actively working to address the issue and restore normal performance as quickly as possible.

We will provide an update when more information is available.
Posted Aug 27, 2026 - 11:58 EDT
This incident affected: Network & WiFi (WiFi (RowanSecure, RowanWiFi & Eduroam)).