Rowan System Status
Subscribe To Updates

RowanSecure issues under investigation

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue impacting RowanSecure.

RowanSecure should now be operating as expected.

If you have any questions, please contact the Technology Support Center at 856-256-4400.
Posted Aug 24, 2026 - 11:13 EDT

Investigating

Information Resources & Technology is investigating an issue affecting sporadic access to RowanSecure.

Some users may intermittently experience issues connecting to or using RowanSecure.

We are working to address this issue as quickly as possible and will provide an update when more information is available
Posted Aug 24, 2026 - 09:28 EDT
This incident affected: Network & WiFi (WiFi (RowanSecure, RowanWiFi & Eduroam)).