Rowan System Status
Subscribe To Updates

Issue accessing virtual desktops and apps

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue that was affecting access to virtual desktops and applications. You may need to log off and launch a new session to restore access.
Posted Jun 02, 2025 - 10:44 EDT

Investigating

Information Resources & Technology is investigating an issue preventing some users from accessing virtual desktops and applications in Citrix. You may not be able to see your virtual desktop, and some applications may not load. We're working to restore service as soon as possible.
Posted Jun 02, 2025 - 09:49 EDT
This incident affected: Virtual Desktops & Applications in Citrix (access.rowan.edu) (Academic Desktop, Employee Desktop).