Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 22, 2025 - 21:00 EDT
Scheduled
Information Resources & Technology will be performing urgent maintenance that may cause interruptions to network services during the evening hours this week.
From Tuesday, June 17, to Sunday, June 22, you may be intermittently unable to access most Rowan applications and websites, including our single sign-on system, Citrix (access.rowan.edu), Rowan NetID, Banner, Canvas and rowan.edu, from on or off campus between 9 p.m. and midnight.
We must complete this maintenance to address newly identified security concerns. Thank you for your patience as we complete this necessary work.
Posted Jun 17, 2025 - 13:27 EDT
This scheduled maintenance affected: Banner (Self-Service Banner (ssb.rowan.edu), Banner Administrative Pages (banner9.rowan.edu/applicationNavigator/seamless)), Printing (Mobile Print (mobileprint.rowan.edu), Network Printing), Microsoft 365 (Exchange Email (outlook.office.com), Office 365 Portal (portal.office.com)), Google Apps (Rowan Gmail (mail.students.rowan.edu), Google Drive (drive.google.com)), Video Conferencing (Webex (rowan.webex.com), Zoom (rowan.zoom.us)), Virtual Desktops & Applications in Citrix (access.rowan.edu) (Academic Desktop, Employee Desktop), Canvas (canvas.rowan.edu), Rowan NetID (netid.rowan.edu), Single Sign-On Service (login.rowan.edu/cas), and Internet, Networking & Phones (Rowan VPN (vpn.rowan.edu), Network File Storage (Openarea & Home Directory)).