Rowan System Status
Subscribe To Updates

Issue affecting employee parking pass selection

Incident Report for Rowan University

Resolved

The vendor has resolved the issue impacting employees from selecting their applicable parking pass.

All employees can now select their parking pass.
Posted Aug 05, 2026 - 15:02 EDT

Investigating

Information Resources & Technology is aware of an issue preventing employees from selecting parking passes and is working with the vendor to resolve.

We will provide another update when more information is available.
Posted Aug 03, 2026 - 11:22 EDT
This incident affected: Other Software & Services (Not Listed).