Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2025 - 05:00 EDT
Scheduled
Information Resources & Technology will be performing system maintenance that will affect access to virtual desktops and applications in Citrix on Wednesday, March 26, from 5 a.m. to 6 a.m.
You will be unable to log in to the Academic Virtual Desktop, Employee Desktop and other virtual applications through access.rowan.edu during that one-hour maintenance period. Any active sessions will also be shut down when the maintenance begins.
We will also be updating the Duo two-factor authentication prompt for access.rowan.edu as part of this maintenance to match the experience on most other applications, including Canvas, Self-Service Banner and Google Drive.
Posted Mar 24, 2025 - 13:02 EDT
This scheduled maintenance affected: Virtual Desktops & Applications in Citrix (access.rowan.edu) (Academic Desktop, Employee Desktop).