Rowan System Status
Subscribe To Updates
Unable to log into access.rowan.edu
Incident Report for Rowan University
Resolved
Information Resources & Technology has resolved the issue preventing users from logging into access.rowan.edu.

We apologize for any inconvenience.
Posted Jan 09, 2025 - 14:55 EST
Investigating
Information Resources & Technology is aware of an issue preventing users from logging into access.rowan.edu. You will stay on the login screen with the message “Your request is being processed”.

Technicians are actively working on resolving this issue as quickly as possible. Updates will be provided as they are available.
Posted Jan 09, 2025 - 13:55 EST
This incident affected: Virtual Desktops & Applications in Citrix (access.rowan.edu) (Academic Desktop, Employee Desktop).