Rowan System Status
Subscribe To Updates

Finesse is currently unavailable: 11-26-25

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue preventing the call center operations from logging into Finesse.

Phones are now open for the applicable teams.
Posted Nov 26, 2025 - 09:05 EST

Investigating

Information Resources & Technology is investigating an issue affecting access to Finesse, the system used for call center operations.

Users are currently unable to access Finesse.

We are working to restore service as quickly as possible.

If you need support from IRT during this outage, please email support@rowan.edu. For any other customer-facing team, please email the applicable team.
Posted Nov 26, 2025 - 08:02 EST
This incident affected: Internet, Networking & Phones (Phones & Voicemail).