Rowan System Status
Subscribe To Updates

Verizon is experiencing a partial outage

Incident Report for Rowan University

Resolved

Verizon has reported that the partial outage from Jan 14 has been resolved.
Posted Jan 15, 2026 - 07:37 EST

Update

We are continuing to investigate this issue.
Posted Jan 14, 2026 - 14:59 EST

Investigating

Information Resources & Technology is aware that Verizon is experiencing a partial outage. More information can be found at:

https://www.wired.com/story/verizon-outage-knocks-out-us-mobile-service-including-some-911-calls/

No Rowan-managed services are impacted. However, you may have issues if using Verizon for Duo authentication or remote access.

We will continue to monitor their progress and update you as more information becomes available.
Posted Jan 14, 2026 - 14:57 EST