Information Resources & Technology has resolved the issue affecting access to rowan.edu websites and applications..
The issue started around 11 p.m. on Tuesday night and was fully resolved by 8:30 a.m. this morning. Affected services included Canvas, Self-Service Banner, Banner Administrative Pages, Rowan University websites and other rowan.edu applications.
All rowan.edu websites and applications are now working as expected.
Posted Oct 29, 2025 - 08:54 EDT
Investigating
Information Resources & Technology is investigating an issue that is affecting access to services, including but not limited to: CAS, Rowan.edu, Canvas, SSB, Banner Admin, Confluence, Mobileprint, etc.
We are working to restore these services as soon as possible, but we do not yet have an estimated time of repair.
Access to email, Rowan WiFi and phones are not impacted.
Posted Oct 29, 2025 - 07:53 EDT
This incident affected: Banner (Self-Service Banner (ssb.rowan.edu), Banner Administrative Pages (banner9.rowan.edu/applicationNavigator/seamless)), Printing (Mobile Print (mobileprint.rowan.edu)), and Canvas (canvas.rowan.edu), Single Sign-On Service (login.rowan.edu/cas).