Rowan System Status
Subscribe To Updates

Citrix Employee Desktop issue under investigation

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue preventing some people from accessing applications in the Citrix Employee Desktop.

Technicians will continue to monitor Citrix throughout the day.
Posted Jan 06, 2026 - 08:55 EST

Investigating

Information Resources & Technology is investigating an issue affecting access to the Citrix Employee Desktop.

Users can log in to Citrix, but are receiving the error message ‘no workstations are available'.

We are working to address this issue as quickly as possible and will provide an update when more information is available.
Posted Jan 06, 2026 - 08:32 EST
This incident affected: Virtual Desktops & Applications in Citrix (access.rowan.edu) (Academic Desktop, Employee Desktop).