Rowan System Status
Subscribe To Updates

Canvas Disruption at Rowan, Across the Nation

Incident Report for Rowan University

Resolved

Service to Canvas has been fully restored.

Faculty who may have communicated alternate plans are encouraged to affirm previous communication to students to ensure clarity.

Students are encouraged to check for additional communication from their faculty but should assume their most recent communication by their professor still stands.

Please check your Rowan email or Canvas for the most recent communication.
Posted May 08, 2026 - 06:26 EDT

Update

Canvas, the learning management system, is currently unavailable at institutions across the nation due to an issue being experienced by the vendor that operates the system–Instructure.

This is a widespread issue affecting many colleges, universities and schools. It is not a breach of Rowan’s internal systems or networks.

At this time, Canvas access is unavailable through the web platform and mobile app. Instructure is working to secure and restore service, and Rowan Information Technology Services is monitoring the situation closely.

While Canvas is unavailable:

- Faculty should communicate with students by Rowan email.
- Students should watch their Rowan email for course-specific instructions from their faculty.

Please note, Canvas message content may have been exposed, which means phishing attempts may appear more convincing than usual. Scammers may reference real course names, assignments, faculty names, student names, or previous Canvas Inbox conversations.

Your Rowan credentials remain secure, and you do not need to change your password at this time. Please be especially cautious.
- Do not click links in unexpected emails claiming to provide Canvas access, grade updates, assignment extensions, or account support.
- Do not enter your Rowan password anywhere other than official Rowan login pages.

We do not yet know when access to Canvas will be restored. Information Resources and Technology is working with Academic Affairs to support course continuity, grading, and end-of-semester needs while Canvas remains unavailable.
Posted May 07, 2026 - 22:16 EDT

Investigating

Information Resources & Technology is aware that Canvas is not available.

We will provide our next update as soon as more information becomes available.
Posted May 07, 2026 - 16:45 EDT
This incident affected: Academic Systems (Canvas (canvas.rowan.edu)).