Rowan System Status
Subscribe To Updates

Zoom integration issue in Canvas

Incident Report for Rowan University

Resolved

The issue impacting the Zoom integration in Canvas has been resolved.

Faculty can now create Zoom sessions within Canvas.
Posted Jan 28, 2026 - 08:15 EST

Update

Information Resources & Technology and Rowan Online continue to work with Zoom support to resolve this issue.

For Faculty & Staff
Access Zoom Externally: Log in through the Rowan Zoom portal at rowan.zoom.us or via the Zoom desktop application to host or schedule meetings.

Share Links via Announcements: To ensure students can join your sessions, please copy your meeting link from the Zoom web portal and post it as a Canvas Announcement.
Alternative Platform (WebEx): The Canvas WebEx app remains fully functional and is available as an alternative for all virtual meetings and lectures.

For Students
Accessing Meetings: You can still access scheduled Zoom meetings, but you will not be able to do so via the "Zoom" tab in Canvas.
Where to Look: Please check your Canvas Announcements or Rowan email for direct meeting links provided by your instructors.

There are no issues with Zoom outside of Canvas.
Posted Jan 28, 2026 - 07:22 EST

Investigating

For Faculty & Staff
Access Zoom Externally: Log in through the Rowan Zoom portal at rowan.zoom.us or via the Zoom desktop application to host or schedule meetings.

Share Links via Announcements: To ensure students can join your sessions, please copy your meeting link from the Zoom web portal and post it as a Canvas Announcement.
Alternative Platform (WebEx): The Canvas WebEx app remains fully functional and is available as an alternative for all virtual meetings and lectures.

For Students
Accessing Meetings: You can still access scheduled Zoom meetings, but you will not be able to do so via the "Zoom" tab in Canvas.
Where to Look: Please check your Canvas Announcements or Rowan email for direct meeting links provided by your instructors.

There are no issues with Zoom outside of Canvas.
Posted Jan 23, 2026 - 11:27 EST
This incident affected: Video Conferencing (Zoom (rowan.zoom.us)).