Rowan System Status
Subscribe To Updates

Issues accessing network services under investigation

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue affecting access to Rowan network services.

All services have been restored.
Posted Mar 28, 2025 - 08:18 EDT

Investigating

Information Resources & Technology is investigating an issue affecting access to Rowan Network services.

You may be intermittently unable to log in to Citrix (access.rowan.edu) and other applications due to this issue, as well as experience slowness when using certain applications.
Posted Mar 28, 2025 - 07:21 EDT
This incident affected: Virtual Desktops & Applications in Citrix (access.rowan.edu) (Academic Desktop, Employee Desktop).