Rowan System Status
Subscribe To Updates

Issues accessing Virtua's Citrix environment

Incident Report for Rowan University

Resolved

Information Resources & Technology has a solution for Rowan-managed computers that are experiencing the PRD Hyperspace error.

Please see our Knowledge Base article at https://support.rowan.edu/kb_view.do?sysparm_article=KB0015077 for the steps to correct this issue.
Posted May 12, 2026 - 08:31 EDT

Identified

Information Resources & Technology is aware that some SOM users are not able to access Virtua’s Citrix environment.

IRT is working closely with Virtua IT to resolve this issue as quickly as possible.

As a workaround, you can:

- Log in to access.rowan.edu
- Launch Employee Desktop
- Open Google Chrome and browse to citrix.virtua.org

This issue does not impact the Rowan Academic or Employee Desktops.

Additional information will be provided as it becomes available.
Posted May 07, 2026 - 17:04 EDT
This incident affected: Other Software & Services (Not Listed).