Instructure, the vendor for Canvas has resolved the API Keys issue.
The errors affecting some Canvas-integrated systems have been resolved. To fully restore functionality, Canvas engineers have reissued specific application keys.
You may be prompted to re-authorize access to these tools. This is a Canvas process. Please follow the on-screen prompts to re-authorize.
Posted May 04, 2026 - 08:28 EDT
Update
Instructure, the vendor for Canvas, continues to investigate the issue impacting Kaltura and UDOIT in Canvas.
Updates will be provided as they are available from the vendor.
Posted May 01, 2026 - 15:33 EDT
Investigating
Canvas is currently experiencing a limited disruption affecting tools that rely on API keys. Instructure, the vendor, is actively investigating the issue and has taken precautionary steps to maintain service stability while they work to restore full functionality.
Some Rowan users may experience issues with integrated services, specifically Kaltura and UDOIT.
Posted May 01, 2026 - 09:15 EDT
This incident affected: Academic Systems (Canvas (canvas.rowan.edu)).