Rowan System Status
Subscribe To Updates

DegreeWorks is Unavailable: 10-20-25

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue preventing access to DegreeWorks.

We apologize for any inconvenience.
Posted Oct 20, 2025 - 07:56 EDT

Investigating

Information Resources & Technology is investigating an issue affecting access to DegreeWorks across all campuses.

Users may see a “Service Unavailable” error message when trying to access DegreeWorks.

We are working to resolve this issue as quickly as possible and will provide an update when more information is available.
Posted Oct 20, 2025 - 07:18 EDT
This incident affected: Other Software & Applications (DegreeWorks (degreeworks-dashboard.rowan.edu)).