Rowan System Status
Subscribe To Updates

Issue impacting RowanWifi and RowanSecure: 7-11-2025

Incident Report for Rowan University

Resolved

Information Resources & Technology was aware of an issue affecting access to WiFi across all Rowan University campuses. Users in some areas were unable to connect to RowanWiFi and RowanSecure.

This issue has been resolved. If you continue to have issues, please reboot your computer.
Posted Jul 12, 2025 - 13:35 EDT

Investigating

Information Resources & Technology is investigating an issue affecting access to WiFi across all Rowan University campuses.

Users in some areas are currently unable to connect to RowanWiFi and RowanSecure.

We are working to address the issue as quickly as possible and will provide an update when more information is available.
Posted Jul 12, 2025 - 10:33 EDT
This incident affected: Internet, Networking & Phones (WiFi (RowanSecure, RowanWiFi & Eduroam)).