Rowan System Status
Subscribe To Updates

Phone service issue affecting outbound calls

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue that was affecting inbound and outbound calls on Rowan University phones. All phone services should now be working as expected.

No other IT services were impacted by this issue. The automated voice message sent this morning that indicated there was a broader outage was sent in error.
Posted Mar 11, 2026 - 10:13 EDT

Investigating

Information Resources & Technology is investigating an issue affecting outbound phone calls on the Rowan phone system.

At this time, internal phone communication is working normally, but some users may experience audio issues when making outbound calls.

In addition, incoming phone calls to Rowan Dispatch are currently unavailable. If you have an emergency, please call 911.

We are actively investigating the issue and working to restore normal service as quickly as possible. We will provide an update when more information is available.
Posted Mar 11, 2026 - 07:55 EDT
This incident affected: Internet, Networking & Phones (Phones & Voicemail).