Rowan System Status
Subscribe To Updates

Unable to access several applications: 04-18-2025

Incident Report for Rowan University

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 09:58 EDT

Investigating

Information Resources & Technology is aware of an issue impacting access to several applications, including but not limited to OnBase, Confluence, Cisco AnyConnect.

Technicians are actively working on resolving this issue as quickly as possible.

Updates will be provided as they are available.
Posted Apr 18, 2025 - 08:43 EDT
This incident affected: Other Software & Applications (Confluence (confluence.rowan.edu), OnBase (onbase.rowan.edu)).