Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 10, 2026 - 22:00 EST
Scheduled
Information Resources & Technology will be performing maintenance that may cause intermittent interruptions to network services on Saturday, January 10, from 10 p.m. to midnight
You may be intermittently unable to access most Rowan applications and websites, including our single sign-on system, Citrix (access.rowan.edu), Rowan NetID, Banner, Canvas and rowan.edu, from on or off campus during that two-hour maintenance window.
Posted Jan 08, 2026 - 11:32 EST
This scheduled maintenance affected: Banner (Self-Service Banner (ssb.rowan.edu), Banner Administrative Pages (banner9.rowan.edu/applicationNavigator/seamless)), Virtual Desktops & Applications in Citrix (access.rowan.edu) (Academic Desktop, Employee Desktop), and Canvas (canvas.rowan.edu), Rowan NetID (netid.rowan.edu), Single Sign-On Service (login.rowan.edu/cas).