Rowan System Status
Subscribe To Updates

Rowan Wifi Issue: 10-20-25

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue impacting the Rowan Wifi

You are now able to successfully connect.
Posted Oct 20, 2025 - 10:25 EDT

Investigating

Information Resources & Technology is investigating an issue affecting access to RowanWiFi.

Some users are receiving an “Unable to authenticate” or similar message when trying to connect to wireless networks.

We are working to address this issue as quickly as possible. We will provide an update when more information is available.
Posted Oct 20, 2025 - 09:22 EDT
This incident affected: Internet, Networking & Phones (WiFi (RowanSecure, RowanWiFi & Eduroam)).