Rowan System Status
Subscribe To Updates

Network is down at South Jersey Tech Park

Incident Report for Rowan University

Resolved

Information Resources & Technology and our vendor have resolved the network outage in the South Jersey Technology Park.

All Rowan Network resources are now working as expected.
Posted Mar 25, 2025 - 15:25 EDT

Update

Information Resources & Technology is aware of an outage affecting Rowan Network resources, including wired and wireless internet access and phones, in the South Jersey Technology Park.

This outage is not affecting network services provided by third-party vendors, like Verizon and Comcast, to tenants in the building.

RowanCard access to the building will continue to work for employees and tenants who have previously accessed the building, though it will not work for individuals who have never accessed the building before.

The outage to Rowan Network resources was caused by an accidental fiber cut. We are working with our vendor to schedule a repair to the broken fiber, but we don’t expect them to be available until this evening. Once on site, the repair generally takes between four to eight hours, depending on the extent of the cut.

We expect network connectivity to be restored to the building by tomorrow, but we will provide an update later this afternoon or evening, when more information is available.
Posted Mar 25, 2025 - 11:28 EDT

Identified

Information Resources & Technology is aware that the network is down at the South Jersey Tech Park.

IRT is on site and the vendor has been engaged. Updates will be provided as they are available.
Posted Mar 25, 2025 - 10:37 EDT