Rowan System Status
Subscribe To Updates

Students are not able to log in to Medicat

Incident Report for Rowan University

Resolved

The Medicat vendor has resolved the issue impacting students from logging in and uploading their wellness documentation.

All students are now able to access Medicat.
Posted Jun 17, 2026 - 07:30 EDT

Investigating

Information Resources & Technology is aware of an issue affecting access to Medicat.

Students attempting to log in to Medicat to upload wellness forms are receiving the error message: "Page isn't working. login.rowan.edu redirected you too many times. ERR_TOO_MANY_REDIRECTS"

As a result, students are currently unable to access Medicat or submit required wellness documentation.

The vendor has been contacted to resolve this issue as quickly as possible.
Posted Jun 16, 2026 - 13:03 EDT
This incident affected: Other Software & Services (Not Listed).