Rowan System Status
Subscribe To Updates

Degree Works is currently unavailable

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue affecting access to Degree Works.

All services should now be operating as expected. If you continue to experience issues accessing Degree Works, please try refreshing your browser or logging out and back in.
Posted May 04, 2026 - 11:28 EDT

Update

Information Resources & Technology continues to troubleshoot the issue affecting access to Degree Works.

We are working to restore service as quickly as possible and will provide an update when more information is available.
Posted May 04, 2026 - 11:10 EDT

Investigating

Information Resources & Technology is investigating an issue affecting access to Degree Works.

Users are receiving the error 'Http/1.1 Service Unavailable' when accessing Degree Works.

We are working to restore access as quickly as possible.

We will provide an update when more information is available.
Posted May 04, 2026 - 08:47 EDT
This incident affected: Academic Systems (DegreeWorks (degreeworks-dashboard.rowan.edu)).