Rowan System Status
Subscribe To Updates

Some employees are receiving an error access WTE

Incident Report for Rowan University

Resolved

The issue impacting access to Web Time Entry has been resolved.

All employees are now able to successfully access their timesheets.
Posted Mar 20, 2026 - 10:02 EDT

Investigating

Information Resources & Technology is investigating an issue affecting access to Web Time Entry.

Some employees are receiving the following error when attempting to enter time: “Extraction of time transaction not allowed.”

We are working to address this issue as quickly as possible. Updates will be provided as more information is available.
Posted Mar 20, 2026 - 09:53 EDT
This incident affected: Banner (Self-Service Banner (ssb.rowan.edu)).