Rowan System Status
Subscribe To Updates

Issue affecting Title IX and Sexual Harassment Prevention for Employees training

Incident Report for Rowan University

Investigating

Information Resources & Technology is aware of an issue affecting access to the Title IX and Sexual Harassment Prevention for Employees training.

Users may be unable to access or complete the training in the Rowan Training Portal/Healthstream at this time.

The Office of Human Resources and the Office of Student Equity & Compliance are working with the vendor to resolve this issue as quickly as possible.

We will provide an update when more information is available.
Posted Jul 06, 2026 - 11:58 EDT
This incident affects: Websites & Portals (Rowan Training Portal (Healthstream)).