Rowan System Status
Subscribe To Updates

Delay in emails being received

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue impacting a delay in emails being received.

All pending emails have been sent.
Posted Mar 28, 2025 - 14:22 EDT

Investigating

Information Resources & Technology is aware of an issue that is causing a delay in emails being received. This issue affects emails sent from Outlook, Banner, ServiceNow, etc.

Technicians are aware of this issue and are actively working to resolve. Updates will be provided as they are available.
Posted Mar 28, 2025 - 12:36 EDT
This incident affected: Microsoft 365 (Exchange Email (outlook.office.com)).