Microsoft has confirmed that the issue impacting Exchange Online and other functionality has been resolved.
Posted Nov 26, 2024 - 16:03 EST
Update
Microsoft has reported that they continue to address lingering issues with Outlook on the web affecting some users. They are also investigating mail queuing delays causing longer delivery times.
IRT will continue to monitor their site and provide updates as they are available.
Posted Nov 26, 2024 - 07:35 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 25, 2024 - 18:16 EST
Monitoring
Microsoft has implemented a fix and is seeing improved performance. They will continue to monitor and apply additional fixes until this issue is fully resolved.
Posted Nov 25, 2024 - 18:13 EST
Identified
Information Resources & Technology is aware of an issue sporadically impacting access to Outlook. Microsoft is actively working on a fix and is providing updates. IRT will continue to monitor the updates from Microsoft and share them as they become available.
If you have any questions, please contact the Technology Support Center at 856-256-4400, or log in to support.rowan.edu and click Get Help.
Posted Nov 25, 2024 - 12:33 EST
This incident affected: Microsoft 365 (Exchange Email (outlook.office.com)).