Rowan System Status
Subscribe To Updates

Issue accessing some Rowan websites

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue preventing some people from accessing various Rowan websites.

Please do not hesitate to contact us if you have any questions.
Posted Apr 14, 2025 - 12:13 EDT

Identified

Information Resources & Technology has identified the issue preventing some people from accessing various Rowan websites. Remediation steps are now being taken.

Everyone is now able to access all Rowan webpages.
Posted Apr 11, 2025 - 13:56 EDT

Investigating

Information Resources & Technology is aware of an issue that is preventing some people from accessing various websites. This includes, but is not limited to rowan.edu webpages, go.rowan pages, etc.

Technicians are actively working on resolving this issue as quickly as possible. Updates will be provided as they are available.
Posted Apr 11, 2025 - 12:07 EDT