Rowan System Status
Subscribe To Updates

Zoom is Currently Down

Incident Report for Rowan University

Resolved

Zoom has resolved the issue that caused the outage to their application.

Updates can be found at: https://status.zoom.us/
Posted Apr 16, 2025 - 17:28 EDT

Investigating

Information Resources & Technology is aware that Zoom is currently down.

We are monitoring the Zoom site and will provide updates as they are available.
Posted Apr 16, 2025 - 15:50 EDT
This incident affected: Video Conferencing (Zoom (rowan.zoom.us)).