Rowan System Status
Subscribe To Updates

Academic and Employee Desktop issue affecting all campuses

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue affecting access to the Academic and Employee Desktops.

All users are able to access the applicable desktop.
Posted May 05, 2026 - 08:18 EDT

Investigating

Information Resources & Technology is investigating an issue affecting access to Academic and Employee Desktops across all campuses.

Some users are currently unable to open the Academic and Employee Desktops.

We are actively investigating this issue and working to restore access as quickly as possible.

We will provide an update when more information is available.
Posted May 05, 2026 - 07:33 EDT
This incident affected: Academic Systems (Virtual Academic Desktop in Citrix) and Business Systems (Virtual Employee Desktop & Applications in Citrix).