Rowan System Status
Subscribe To Updates

Self-Service Banner issue: Students not able to email their schedule

Incident Report for Rowan University

Identified

Information Resources & Technology is aware of an issue preventing users from emailing their calendars from Self-Service Banner.

A workaround is available. Please see our Knowledge Base article for instructions on using a browser extension to email your calendar:

https://support.rowan.edu/kb_view.do?sysparm_article=KB0015123.

We are working with the vendor to resolve this issue. We will provide an update when a permanent fix is available.
Posted Sep 03, 2026 - 14:06 EDT

Investigating

Information Resources & Technology is aware of an issue affecting Self-Service Banner that is preventing students from emailing their schedules to themselves.

We are working to address this issue as quickly as possible.

We will provide an update when more information is available.
Posted Sep 01, 2026 - 08:34 EDT
This incident affects: Banner (Self-Service Banner - Student (ssb.rowan.edu)).