Rowan System Status
Subscribe To Updates

OnBase via access.rowan is down

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue preventing access to OnBase in access.rowan.edu.
Posted Apr 23, 2025 - 11:44 EDT

Identified

Information Resources & Technology is aware of an issue preventing access to OnBase in access.rowan.edu.

Technicians are working on resolving this as quickly as possible.
Posted Apr 23, 2025 - 11:23 EDT
This incident affected: Other Software & Applications (OnBase (onbase.rowan.edu)).