Rowan System Status
Subscribe To Updates

Self-Service Banner and Banner Administrative Pages access issue

Incident Report for Rowan University

Resolved

Information Resources & Technology has resolved the issue affecting access to Self-Service Banner and Banner Administrative Pages.

All services should now be operating as expected.
Posted Aug 17, 2026 - 18:55 EDT

Investigating

Information Resources & Technology is investigating an issue affecting access to Self-Service Banner and Banner Administrative Pages.

Some users may be unable to access these services.

We are working to address this issue as quickly as possible and will provide an update when more information is available.
Posted Aug 17, 2026 - 17:17 EDT
This incident affected: Banner (Self-Service Banner - Student (ssb.rowan.edu), Self-Service Banner - Faculty & Staff (ssb.rowan.edu), Banner Administrative Pages (banner9.rowan.edu/applicationNavigator/seamless)).