Rowan System Status
Subscribe To Updates

WiFi issue affecting SSVM and Glassboro

Incident Report for Rowan University

Resolved

Information Resources & Technology continued to monitor RowanWiFi and RowanSecure following the reported issues earlier this week.

All services are operating as expected.
Posted Sep 02, 2026 - 12:32 EDT

Monitoring

Information Resources & Technology is seeing improved connectivity on RowanWiFi and RowanSecure.

We will continue to monitor the networks to ensure service remains stable.

Additional updates as more information becomes available.
Posted Sep 01, 2026 - 14:06 EDT

Update

Information Resources & Technology is troubleshooting issues affecting access to RowanWiFi and RowanSecure on the Glassboro campus.

We are working to address the issue as quickly as possible and will provide an update when more information is available.
Posted Sep 01, 2026 - 09:18 EDT

Update

Information Resources & Technology continues to troubleshoot sporadic WiFi issues at SSVM.

We are working to address this issue as quickly as possible and will provide an update when more information is available.
Posted Sep 01, 2026 - 08:35 EDT

Investigating

Information Resources & Technology is investigating an issue affecting WiFi access in some classrooms at the Shreiber School of Veterinary Medicine.

Users in affected classrooms may experience difficulty connecting to or maintaining a connection to Rowan’s wireless networks.

We are working to address this issue as quickly as possible and will provide an update when more information is available.
Posted Aug 31, 2026 - 09:18 EDT
This incident affected: Network & WiFi (WiFi (RowanSecure, RowanWiFi & Eduroam)).