Rowan System Status
Subscribe To Updates

Maintenance to briefly interrupt internet access on 3-19-2026

Scheduled for Mar 19, 20:00 - 22:00 EDT

Update

This work has been postponed until Thursday, March 19.
Posted Mar 05, 2026 - 08:32 EST

Scheduled

One of Rowan University's internet service providers has scheduled maintenance that will briefly affect access to the internet for some users on Thursday, March 5, from 10 p.m. to midnight.

Internet access will remain available throughout the maintenance window through our second internet service provider. However, anyone actively connected to the internet through the first provider will notice an interruption as service falls back to the other provider.
Posted Mar 04, 2026 - 19:33 EST
This scheduled maintenance affects: Internet, Networking & Phones (WiFi (RowanSecure, RowanWiFi & Eduroam), Wired (RowanSecure)).