Rowan System Status
Subscribe To Updates

Webex service issues under investigation

Incident Report for Rowan University

Resolved

Cisco has resolved all issues impacting Webex.

All Webex services are available: https://status.webex.com/commercial/status?lang=en_US
Posted Jun 04, 2026 - 07:37 EDT

Monitoring

Information Resources & Technology continues to monitor and work with Cisco as they troubleshoot the issue affecting phone services.

Most services have now been restored. At this time, voicemail remains unavailable while Cisco continues to work toward a full resolution.

We will provide another update when more information is available or when voicemail service has been restored.
Posted Jun 03, 2026 - 13:49 EDT

Identified

Information Resources & Technology is aware of a service degradation affecting some Webex services hosted in Cisco's U.S. data centers.

Users may experience issues with Webex Meetings, Webex Calling, Webex Messaging, and other Webex-related services. The issue appears to affect multiple organizations and is currently under investigation by Cisco.

Information can be found at: https://status.webex.com/commercial/status?lang=en_US.

We will provide an update when more information becomes available.
Posted Jun 03, 2026 - 10:34 EDT
This incident affected: Email & Collaboration (Webex (rowan.webex.com)).