Rowan System Status
Subscribe To Updates

Issue affecting internet, application access

Incident Report for Rowan University

Resolved

Information Resources & Technology has fully resolved the issue that affected on-campus internet access and on- and off-campus access to Rowan University applications yesterday morning.

Since we implemented the workaround at 11:15 a.m. yesterday, there have been no further customer-facing issues, and IT services have been operating as expected. We continued to closely monitor the situation overnight and into this morning, and we are confident the underlying issue has been addressed.

Thank you for your patience while we worked to restore services.
Posted Aug 20, 2026 - 10:58 EDT

Monitoring

Information Resources & Technology implemented a workaround at 11:15 a.m. today to restore on-campus internet access and on- and off-campus access to Rowan University applications.

You should now be able to access IT services as expected. If you are continuing to experience any ongoing issues, please contact the Technology Support Center at 856-256-4400 for further assistance.

We are continuing to investigate the root cause of this issue. We don’t expect any further extended outages. However, there may be intermittent issues as we work with our vendors to fully resolve this issue.
Posted Aug 19, 2026 - 12:04 EDT

Update

We are continuing to investigate this issue in partnership with our vendors. We do not yet have an ETA for resolution. We will provide another update as soon as new information is available.
Posted Aug 19, 2026 - 10:28 EDT

Update

We are continuing to investigate this issue.
Posted Aug 19, 2026 - 09:30 EDT

Investigating

Information Resources & Technology is investigating an issue that is affecting access to internet on-campus. This issue is also affecting access to some Rowan University applications, as well as off-campus access to the Rowan VPN.
Posted Aug 19, 2026 - 09:26 EDT
This incident affected: Banner (Self-Service Banner - Student (ssb.rowan.edu), Self-Service Banner - Faculty & Staff (ssb.rowan.edu)), Network & WiFi (WiFi (RowanSecure, RowanWiFi & Eduroam), Wired Network Access, Rowan VPN - Rowan-Managed Devices (gp.rowan.edu)), and Accounts & Login (Single Sign-On Service (login.rowan.edu/cas)).