Information Resources & Technology has resolved all network and phone issues that impacted the Stratford campus.
Posted Sep 11, 2025 - 09:18 EDT
Identified
Information Resources & Technology has resolved the network, printing, and phone issues in the Academic Center, except for some areas in the gymnasium.
Technicians continue to work on resolving this issue. Updates will be provided when they become available.
Posted Sep 10, 2025 - 15:46 EDT
Update
Information Resources & Technology has resolved the network, printing and phone issues at the Rowan Medicine Building (UDP). Technicians are continuing to work on the Academic Center.
Updates will be provided as they are available.
Posted Sep 10, 2025 - 12:51 EDT
Investigating
Information Resources & Technology is investigating an issue affecting some access to network and phone services on the Stratford campus.
You may be unable to connect to the Rowan Network or place/receive calls at this time.
We are working to address this issue as quickly as possible, and we will provide an update when more information is available.