Information Resources & Technology is aware that some non-Rowan-managed (personal) Windows computers may have an issue connecting to RowanWifi.
This issue is due to a recent Windows update that affects network connectivity. Rowan-managed Windows machines are not impacted.
If you experience a problem connecting to RowanWifi on a non-managed Windows machine, you can temporarily resolve it by rebooting your computer.
If you continue to have difficulties connecting to RowanWifi, please contact the Technology Support Center at 856-256-4400 or visit the in-person IRT support on your campus.
Posted Mar 13, 2026 - 10:48 EDT
Investigating
Information Resources & Technology is aware that some non-Rowan-managed Windows computers may have an issue connecting to RowanWifi.
IRT is actively investigating this issue and is working on a solution.
Updated information will be provided as it becomes available.