Rowan System Status
Subscribe To Updates

Qualtrics is currently not available

Incident Report for Rowan University

Identified

Information Resources & Technology continues to work with the vendor, Qualtrics, to resolve this issue as quickly as possible.

At this time, all users are impacted.

Updates will be provided as more information becomes available.
Posted Feb 26, 2026 - 13:01 EST

Investigating

Information Resources & Technology is currently investigating an issue affecting Qualtrics.

The application became unavailable earlier today and is displaying an “Organization is disabled” error message.

At this time, all users are impacted. We are working with the vendor to restore service as quickly as possible.

Updates will be provided as more information becomes available.
Posted Feb 26, 2026 - 09:57 EST
This incident affects: Other Software & Applications (Qualtrics (rowan.qualtrics.com)).